Home تكنولوجيا جوجل تعلن رسميًا نهاية إصدار أندرويد جيلي بين

جوجل تعلن رسميًا نهاية إصدار أندرويد جيلي بين

0
SHARE
نهاية جيلي بين
نهاية جيلي بين

في الوقت الذي تخلت فيه الشركات المصنعة عن الأجهزة القديمة جدًا، حافظت شركة جوجل على دعم إصدارات أندرويد التي تعود إلى ما يقرب من عقد من الزمان، طالما أنه لا يزال هناك عدد كافٍ من المستخدمين لتبرير تكلفة الصيانة.

وغالبًا ما يتم انتقاد نظام التشغيل أندرويد بسبب تجزئته. ولكن هذه التجزئة لها تأثيرات جانبية مفيدة.

ومع ذلك، يبدو أن نهاية إصدار أندرويد المسمى جيلي بين Jelly Bean قد حانت مع إعلان جوجل عن إيقاف دعم خدمات جوجل بلاي للأجهزة التي لا تزال تعمل عبر إصدار أندرويد لعام 2012.

ويتميز جيلي بين بوجود أكثر من إصدار أندرويد واحد بنفس الاسم، من أندرويد 4.1 إلى أندرويد 4.3.

وجاء جيلي بين في وقت كان أندرويد فيه لا يزال في حالة من التطور السريع. ولا يبدو أن الإصدارات كانت تتبع إيقاعًا منتظمًا.

وكان جيلي بين إصدارًا كبيرًا جدًا أيضًا، حيث قدم واجهة المستخدم Holo المحسّنة والعديد من التغييرات، مثل دعم البلوتوث المنخفض الطاقة.

وتكشف جوجل أن أندرويد 4.1 حتى أندرويد 4.3 معًا يشكلون الآن أقل من 1 في المئة من الأجهزة النشطة.

ويمنحها ذلك حرية إسقاط الدعم لمستويات Android API (من 16 إلى 18، على التوالي).

وقد يفاجئ البعض أن يسمع أن خدمات جوجل بلاي لا تزال تدعم هذه الأجهزة، وذلك بفضل الطبيعة المعيارية لنظام أندرويد.

وقالت الشركة تم إطلاق منصة أندرويد جيلي بين لأول مرة منذ 9 سنوات. وحصل أندرويد منذ ذلك الحين على الكثير من التحسينات والميزات التي لم يتم نقلها كلها إلى جيلي بين.

وأضافت: يؤدي هذا إلى زيادة وقت المطور الذي يقضيه في الميزات الجديدة التي تتطلب معالجة خاصة. وبالتالي، فإننا نوقف دعم جيلي بين في الإصدارات المستقبلية من خدمات جوجل بلاي.

جوجل تعلن نهاية جيلي بين

توجد خدمات جوجل بلاي الخاصة بشكل منفصل عن نظام أندرويد المفتوح المصدر، ويمكن لعملاقة البحث الحفاظ على دعم الأجهزة القديمة بشكل منفصل، عادةً من خلال مكتبات التوافق.

وتوضح الشركة أنها تسقط الدعم بالنسبة للأجهزة التي تعمل بإصدار جيلي بين بعد الإصدار 21.30.99، المقرر إجراؤه في نهاية شهر أغسطس 2021.

ولا يعني هذا أن هذه الأجهزة تتوقف عن العمل فورًا. ولكنها قد ترى حدوث بعض الأشياء الغريبة، خاصة تلك التي تعتمد على خدمات جوجل بلاي. وهناك احتمال ألا تتمكن من استخدام متجر أيضًا.

وينصح مطورو التطبيقات باستخدام Android API المستوى 19، المعروف أيضًا باسم أندرويد 4.4 كيت كات، كحد أدنى للإصدار المستهدف لتطبيقاتهم.

وهذا يعني أن التطبيقات التي يتم تحديثها إلى ذلك لن تكون مرئية أو قابلة للتثبيت بعد الآن عبر الأجهزة التي لا تزال تستخدم جيلي بين.

ولدى المطورين خيار الاستمرار في إصدار ملف APK يستهدف هذه الإصدارات المهملة. ولكن الشركة تأمل أن يقوم الجميع بالترقية إلى إصدار أندرويد المدعوم بدلاً من ذلك.

المصدر

LEAVE A REPLY

Please enter your comment!
Please enter your name here